【漏洞预警】ThinkPHP5 核心类Request远程代码执行高危漏洞

SetYun 发表于 2019-1-21 09:41:46 | 显示全部楼层 |阅读模式

2019年1月11日,阿里云云盾应急响应中心监测到ThinkPHP官方发布安全更新,披露了一个高危安全漏洞,攻击者构造特定的恶意请求,可以直接获取服务器权限,受影响的版本包括5.0.0~5.0.23版本及5.1多个版本。



漏洞描述

由于ThinkPHP5框架对Request类的method处理存在缺陷,导致黑客构造特定的请求,可直接GetWebShell。



漏洞评级

严重



影响版本

ThinkPHP 5.0系列 < 5.0.24

ThinkPHP 5.1多个版本



安全版本

ThinkPHP 5.0系列 5.0.24



安全建议

升级ThinkPHP至安全版本

云盾WAF已可防御此漏洞攻击

云盾网站威胁扫描系统已支持对该漏洞检测

云盾态势感知应急漏洞模块已支持对该漏洞一键检测,详情登陆云盾控制台



相关链接

https://blog.thinkphp.cn/910675




我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云云盾应急响应中心

2019.1.11


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|SetYun ( 辽ICP备16005250号

GMT+8, 2021-3-5 05:07 , Processed in 0.042633 second(s), 5 queries , File On.

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表